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ASSESSMENT PATTERN 

CIE- Continuous Internal Evaluation (30 Marks) 

SEE- Semester End Examination (20 Marks) 

Bloom’s Category Tests 

Remember 05 

Understand 07 

Apply 08 

Analyze 07 

Evaluate 08 

Create 05 

SEE- Semester End Examination (40 Marks) (should be converted in actual marks (20)) 

Bloom’s Category Marks  

(out of 100) 

Lab Final 

(30) 

Lab Report 
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Curricular/Final Project Exhibition 

(10) 

Remember/Imitation  05          05       02   

  

Attendance 

10 

Understand/manipulation  05  05 05             03 

Apply/Precision 05   05   

Analyze/Articulation 05   05   

Evaluate/Naturalisation 05        05 05   

Create  05  05 05 

CIE- Continuous Internal Evaluation (100 Marks) (should be converted in actual marks (30)) 
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Course Title: ETABS and SAFE (Complete RCC 

Building Project Development)  

Covered Course: Structural Analysis and Design-

III Sessional  

 

COURSE CODE: CE 0732-3202                                                                                                                                

CREDIT: 01 

CIE MARKS: 30 

SEE MARKS: 20 

 

CLO1 Master Structural Modeling and Analysis: Students will learn to 

model and analyze RCC buildings using ETABS and SAFE, 

incorporating all relevant load combinations such as dead load, live load, 

wind load, and seismic load. 

CLO2 Design Structural and Foundation Elements: Students will be able to 

design key structural elements (beams, columns, slabs) and foundations 

(isolated, combined footings) to meet safety, serviceability, and code 

compliance requirements. 

CLO3 Develop Reinforcement Detailing: Students will gain proficiency in 

generating detailed reinforcement drawings and schedules for all 

structural components, ensuring practical applicability in construction. 

CLO4 

Integrate Cost Estimation and Code Compliance: Students will 

acquire the ability to perform project cost estimation and ensure 

compliance with building codes like BNBC-2020 and ASCE-7, 

optimizing designs for cost efficiency and sustainability. 

 

 



Sl. Course Contents Hours CLOs 

1 Material Assigning: Assigning grade of concrete and steel, 

Inserting the value of E, Poison’s ratio and Density of RC, 

Drawing frame Sections (column & beam). 

Dead and Live Load Assign: Assigning main wall load, 

partition wall load, assigning Parapet wall load, floor 

finished, live loads according to BNBC/ACI guidelines 

Wind and Earthquake Load Assign: Calculating and 

assigning base share in X and Y direction, and assign load 

combination. 

40 CLO 

1, 

CLO 3 

2 Basic Command for SAFE, Design of column footing, 

combined footing, mat foundation, pile foundation and pile 

cap, and group pile. 

20 CLO 

2, 

CLO 3 

3 Complete project submission in pdf file and model 

submission 

20 CLO 4 

 

 

 

References:  

 

Bangladesh National Building Code (BNBC) 1993  

ETABS Version 9.6.2 User’s Guide 

 

 

 

 

 



 

 

WEEK TOPIC TEACHING-LEARNING 

STRATEGY  

ASSESSMENT 

STRATEGY 

CORRESPO-

NDING CLOS 

01-02 Multi-storied building frame by 

ETABS 

LECTURE, DISCUSSION Individual model 

checking 

CLO1 

03-04 Multi-storied building frame by 

ETABS 

LECTURE, DISCUSSION Individual model 

checking 

CLO3 

05 Introduction to the project by SAFE LECTURE, DISCUSSION Individual model 

checking 

CLO1 

06-09 Define various properties of new 

model  

LECTURE, DISCUSSION Individual model 

checking 

CLO2 

10-11 Draw various parts of model and 

add design strips 

LECTURE, DISCUSSION Individual model 

checking 

CLO3 

12-13 Assign Loads, Analysis LECTURE, DISCUSSION Individual model 

checking 

CLO2 

14-15 Design Display, Run the project, 

create Final Report 

 
Individual model 

checking 

CLO3 

16 Doubt Solving Class Discussion   
 

   17 
Final Assessment 

Lab Quiz, Practical 

exam 

Written, Viva CLO1 

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

 

WEEK 01-02 

 

Multi-storied building frame by ETABS 

MULTI-STORIED BUILDING FRAME UNDER ALL LOADS  
 

 

 

 

 

 



Objective: Analyze the following 9-Storied residential building under all loads and find out the 

following items;   

1. Supports Reactions for foundation design  

2. Column Axial forces  

3. Beams forces  

  
 Fig. 4.2:Typical Floor Plan  Fig. 4.3:Elevation view  

 

 

 

  
Fig. 4.1 :   Ground Floor Plan   

  



 
Fig. 4.4: Column Layout Plan  

 
Fig. 4.5: Grade Beam Layout Plan  

 
Fig. 4.6: Typical Floor Beam and Slab Layout Plan  



Table: 4.1 Geometry and Loads  

Properties:  Load Definitions:  

Column:   

C1= 12”X18”  

C2=12”X20”  

Materials=Concrete, f’c=4000 psi Beam:   

GB = 10”X18”  

 FB = 10”X20”  

Materials=Concrete, f’c=4000 psi  

  

Shear wall: Thickness = 8”  

Materials=Concrete, f’c=4000 psi  

  

Slab: Thickness = 6”  

Materials=Concrete, f’c=3000 psi  

   

So, Slab load = (6x150)/12 = 75 psf   

  

• All supports are fixed support  

• Bottom story height = 8’-0”  

• Typical story height = 10’-0”  

• Top story for lift & stair = 8’-0”  

1. Dead Load:  

    Self weight (Factor=1)  

    Floor Finish (FF) = 30 psf   

    Partition wall load (PW) = 25 psf   

    Wall load on beams (W) = 416 Ib/ft (for 5” brick wall)  

  

2. Live Load: LL = 40 psf   

3. Seismic Definition: (Dhaka zone)  

           EQx  & EQy   

4. Wind Definitions: (for Dhaka)  

            Wx  &  Wy   

*Wind speed for Dhaka zone = 210 km/hr  = 

130 mile/hr  

Load Combinations:  

UFL = DL+LL   

FDL = 1.2*DL+1.6*LL  

FDLEQx = 0.9*DL+1.2*LL+1.32*EQx   

FDLEQz = 0.9*DL+1.2*LL+1.32*EQy  

FDLWx =0.9*DL+1.2*LL+1.2*Wx   

FDLWz = 0.9*DL+1.2*LL+1.2*Wy  

  

Procedure:  
1. Grid System and Story data definition: Open ETABS software →File → New Model → no →Units = 

Kip-ft →Number of lines in X-direction= 5→ Number of lines in Y-direction= 4→ Number of 

stories=11→Bottom Story height=8→Typical Story height = 10→ Click on Custom Grid spacing →  

Edit Grid → Click on Spacing →Then X-direction Grid spacing A = 15’3”, B=11’, 

C=17’9”→D=13’6”→E=0→ Then Y-direction Grid spacing 1 = 13’6”, 2=5’9”, 3=9’4”→4=0→ OK → 

Then click on Custom Story Data→Edit Story Data→Now change the Label as GB,  

STORY1…………STORY8, ROOF,OHWT→Height OHWT =8→Elevation, BASE = -8→Master Story, 

STORY1 = Yes→Similar to, BASE,ROOF and OHWT = NONE and from STORY2 to STORY8 = 

STORY1→OK→Grid only→ OK. (Fig: 4.7).  

  

2. Define:  

2.1 Materials Properties: Define → Materials Properties→ Add New Materials →Material Name = 

CONC3(f’c=3000psi)→ Specified Conc. Comp. Strength = 4 → Modulus of Elasticity =  

3122→OK (in the same way define other materials like CONC4 for f’c =4000psi→OK. (Fig: 4.8)  

  

2.2 Frame Sections (for Beam, Column): Define → Frame Sections→ Add Rectangular →Section 
Name = C12X18→ Material = CONC4→ Depth=18, Width = 12 → Reinforcement→Column  



→Cover to Rect. Center= 1.5→OK →OK → OK. (Fig: 4.9). In the same way define other 

Columns and Beams  

 
 

Fig 4.7  

  

  



 

 
2.3 Wall/Slab/Deck Sections: Define→Wall/Slab/Deck sections→SLAB1→Modify/Show Section→ 

Section Name=SLAB6→Material=CONC3→Thickness: Membrane=6, Bending=6→Type: 

Shell→Set Modifiers→Bending m11 Modifier=Bending m11 Modifier=Bending m22 

Modifier=Bending m12 Modifier= 0.00001→ OK →OK → OK.   

(Fig: 4.10).   

In the same way define other Slabs and Shear Walls.  

  

2.4 Static Load Cases: Define →Static Load Cases→Load: SFW, Type: DEAD, Self wt Multiplier:  

1→Modify Load→Again, Load: FF, Type: DEAD, Self wt Multiplier: 0→Add New Load   

  
Fig   4. 8   

  

  
Fig   4.9   

  



Load: PW, Type: DEAD, Self wt Multiplier: 0→Add New Load  

Load: WALL, Type: DEAD, Self wt Multiplier: 0→Add New Load  

Load: EQX, Type: QUAKE, Self wt Multiplier: 0, Auto Lateral Load= UBC 94→Add New Load 

→Modify Lateral Load→X Dir, Seismic Zone factor=1.5, Site coefficient =1.2, Importance 

factor=1, Method A Ct(ft)=0.03, Top story=OHWT, Bottom story= Base, Numerical coefficient  

Rw=8→ OK →OK. (Fig: 4.11, 4.12)   

In the same process define other seismic and wind loads.  

 

 

  

  
Fig   4.10   

  

  
Fig   4.11   



 
  

Fig 4.12  

  



2.5 Load Combinations: Define → Load Combinations →Add New Combo.. →Load Combination 

Name=UDL→Load Combination Type =ADD→ Case Name=SFW static load, Scale 
Factor=1→Add→Case Name=LIVE static load, Scale Factor=1→Add→Case Name=FF static load, 

Scale Factor=1→Add→Case Name=PW static load, Scale Factor=1→Add→Case Name=WALL 

static load, Scale Factor=1→Add→OK  

  

Again→Add New Combo.. →Load Combination Name=FDL→Load Combination Type =ADD→ 

Case Name=SFW static load, Scale Factor=1.2→Modify→Case Name=LIVE static load, Scale 

Factor=1.6→Modify →Case Name=FF static load, Scale Factor=1.2→Modify →Case Name=PW 

static load, Scale Factor=1.2→Modify →Case Name=WALL static load, Scale  

Factor=1.2→Modify →OK. (Fig: 4.13)  

Same process follow for other load combination define and finally press OK.  

 
 

 

 

 

 

 

 

  
Fig   4.13   

  



 

 

 

 

 

 

 

 
 

 

WEEK 03-04 

 

MULTI-STORIED BUILDING FRAME UNDER ALL LOADS  

 

 

 

 

 

 

 

 



3 Draw:  
3.1 Column Draw: Plan view is → Story1 or any other without BASE plan and from bottom select 

→All Story then from menu bar click on Draw → Draw Line Objects → Create Columns in Region 
or at Clicks (Plan) → Select Property = C12X18 →Then draw the Column on plan view by clicking 

on every Column points as your Column Layout Plan. (Fig: 4.14)  

  

3.2 Grade/Floor Beam Draw: Plan view is →GB Plan View and for other Story1 or any other without 
BASE plan and from bottom select →Similar Story then from menu bar click on Draw → Draw 

Line Objects → Click on  Lines (Plan, Elev, 3D) →Select Property = GB10X18→Then draw the line 

on GB Plan View by clicking one point to another point as your given Grade Beam Layout Plan. 
(Fig: 4.15, 4.16)  

 

 
 

 

  

  
Fig . 4.14   

  



 
 

3.3 SLAB Draw: Plan view is →Plan ViewStory1or any other without BASE plan and from bottom 

select →Similar Story then from menu bar click on Draw → Draw Area Objects → Click on  Draw 

Areas (Plan, Elev, 3D) → Select Property = SLAB6→Then draw the Slab by clicking one point to 

another point at anti clockwise rotations your given Slab Layout Plan .  

  

  To display the slab on screen go to View→Set Building View Options→Click on Object 

fill→Apply to all Windows→OK. (Fig: 4.17)  

  
Fig: 4.15   

  
Fig . 4.16   



 

  
Fig. 4.18a  

 

  
3.4   Varandha Draw:   Follow the Fig: 4.18   

  
Fig . 4.17   



 
Fig. 4.18b  

4 Assign:  

4.1 Support Assign: Select the support point at BASE Plan→ Assign →Joint/Point → Restraints 
(Supports) →Then select support type (Fixed, Pin, Roller) by clicking on symbols → OK. (Fig:  

4.19)  

  

4.2 Load Assign:  

4.2.1 Floor Load Assign: Select Slabs→ Assign →Shell/Area Loads→Uniform→Load Case 

Name = Live →Units=Ib-ft →Load= 40→Direction = Gravity→ OK. The same procedure 

follows for other Distributed loads (FF, PW). (Fig: 4.20).  

   

4.2.2 Wall Load Assign: Select Floor Beams→ Assign →Frame/Line Loads  

→Distributed→Load Case Name = WALL→Units=Ib-ft →Direction = Local-2→Then 

write the values of wall Load = 425→ OK. (Fig: 4.21, 4.22)  

  

4.3 Area Mesh and Diaphragm Create:  

4.3.1 Area Mesh: Select Slabs→Assign→ Shell/Area→Area Object Mesh Option→Further 

subdivided Auto Mesh with minimum element size of =3 →OK. (Fig: 4.23)  

  

4.3.2 Diaphragm: Select All→Assign→ Shell/Area→Diaphragm →D1→Modify/Show  

Diaphragm→Rigid →OK→OK. (Fig: 4.24)  



  

  

 

 

 

  
Fig . 4.19   

  

  
Fig . 4.20   

  

  
Fig . 4.21   



 

  
Fig . 4.22   

  
Fig. 4.2 3 a   



 
5 Analysis:  

Go to Analyze→Check Model (mark all checking options)→OK  

Again Go to Analyze→Run Analysis  

  

6 Results:  
6.1 Support Reactions: Go to display →Show Member Forces/Stress Diagram →Support/Spring 

Reactions→Select Load (Live/Dead etc.)→ OK →Select the Support point by click (from the 

display elevation view) →press mouse right button and find out your desirable values like 
vertical force, horizontal force and moment. (Fig: 4.25, 4.26)   

  
Fig . 4.2 3 b   

  
Fig . 4.2 4   



 
6.2 Maximum Shear force on beam AB: Go to display →Show Member Forces/Stress Diagram 

→Frame/Pier/Spandrel Forces…→Select Load (Live/Dead etc.)→Shear 2-2 →Click on Show 

Values on Diagram→ OK →Select the Beam by click (from the display elevation view) →press 
mouse right button and find out your desirable values like vertical force, horizontal force and 

moment. (Fig: 4.27)  

  

6.3 Maximum Bending Moment on beam: Go to display →Show Member Forces/Stress Diagram 
→Frame/Pier/Spandrel Forces…→Select Load (Live/Dead etc.)→Moment 3-3 →Click on Show 

Values on Diagram→ OK →Select the Beam by click (from the display elevation view) →press 

mouse right button and find out your desirable values like vertical force, horizontal force and 
moment. (Fig: 4.28)  

  

  
Fig: 4.25   

  
Fig . 4.26   



 

 
Fig. 4.28  

 

    
Fig . 4.2 7   

  



 

 

 

 

 

 

 

 

WEEK 05 

 

Introduction to the project by SAFE 
 

 

 

 

 

 

 



R/C Example   

The intent of this tutorial is to give you hands-on experience via step-bystep instructions 

on how to use SAFE to model, analyze, design and detail mild reinforced concrete slabs. 

Fundamentals of the model creation process are identified and various model construction 

techniques are introduced. As you complete the tutorial, you will build the model shown in 

Figure 1.  

The Project  
The tutorial project is an irregularly shaped suspended concrete slab, with overall 

dimensions of 113 feet by 120 feet. A large opening exists in the interior for stair access. 

The 10-inch thick slab is supported by 12inch-thick walls, 16-inch-thick drop panels on 

columns, and 18-inch by 24-inch beams on two perimeter sides. Columns are 18 inches 

square, drop panels are typically 6 feet square, and the story height below the slab is 12 

feet. The model will be analyzed for a uniform dead load of 30 pounds per square foot 

(psf) plus the self weight of the structure and a live load of 50 psf.  

Concrete Materials:  

Concrete strength, f’c    = 4000 psi  

Unit weight of concrete =   150 pcf Mild-steel reinforcing:  

fy = 60 ksi  

  
Figure 1 The Project Model  

 



Navigating Through SAFE  
 

The SAFE program provides the user with two principal ways to navigate through program 

commands:  menu commands or toolbar buttons. All commands are available through the 

main menu bar (e.g., Draw menu > Draw Columns), and a majority of the menu 

commands are also available as buttons on toolbars (e.g., Draw Columns, ). The 

availability of a button on the toolbar is indicated in the menus by the  existence of an icon 

to the left of the command, as shown in Figure 2.   

 

In this tutorial, the reference to various commands will be given using the narrative 

description, i.e., Draw menu > Draw Column command, in lieu of the associated button.  

  
Figure 2 Draw Menu  



 

 

 

 

 

WEEK 06-07 

 

BUILDING THE  PROJECT BY SAFE 

 

Define various properties of new 

model  

 



Step 1    Begin a New Model  
In this Step, the dimensions and basic grid will be defined, which will serve as a guide for 

developing the model. This model will be built without using the automated template 

tools provided in SAFE to demonstrate how to construct a model from scratch. However, 

as a general rule, we highly recommend using templates to start models whenever 

possible because they provide a quick, easy way of generating a model. Consult the SAFE 

Help topics for information about templates.  

Define the Grid  

Click the File menu > New Model command to access the New Model Initialization form 

shown in Figure 3. This form is used to 

A. specify the starting point of the model creation: a Blank screen, a screen with a Grid 

Only, or one of eight templates. Default units also may be selected here, along with the 

design code and preferences.   

  
Figure 3 New Model Initialization form  

B. In the Design Data area, select ACI 318-08 from the Design Code drop-down list.  

C. In the Design Data area, verify that the Units are set to Currently US; if not, click the 

Modify/Show button and select the U.S. Defaults on the Units form.  

D. In the Initial Model area, click the Grid Only button to display the Coordinate System 

Definition form shown in Figure 4. This form is used to specify the number of grids and 

spacing in each direction. It is important that the grid is defined so as to accurately 



represent the geometry of the structure; so it is advisable to spend time carefully 

planning the number and spacing of the grid lines. E. Select the Cartesian option.  

F. As shown in Figure 4, set the Number of Grid Lines in the X Direction to 6 and in the Y 

Direction to 7. Set the Spacing in the X Direction to 20 feet and in the Y Direction to 

18 feet.  

  
Figure 4 Coordinate System Definition form  

G. Click the Edit Grid button to display the form shown in Figure 5.  The Coordinate 

System form is used to modify and edit the grid definitions, as well as set the top of 

model datum. It also allows the user to set the display options associated with the 

grids.   

1. In the Display Grid Data as area, select the Spacing option.   

2. In the X Grid Data table, change the X spacing as follows:  

 



  

Figure 5 Coordinate System form  

Grid ID  Change X Spacing to  

A  26  

D  27  

3. In the Y Grid Data table, change the Y spacing as follows:  

Grid ID  Change Y Spacing to  

3  24  

4  24  

4. Click the OK button to accept your changes.  

 

 



Upon closing the Coordinate System form, by default, the grid system displays in the 

main SAFE window, with two windows tiled vertically: a Model Explorer window on 

the left and a Plan View on the right. The number of view windows can be changed 

using the Options menu > Windows command.  

H. Click the View menu > Set Display Options command to display the Set Display 

Options form. Uncheck the Horizon option and click the OK button to exit that 

form. The Horizon option displays a plane that resembles an engineering calculation 

grid to illustrate the datum plane location; we are turning this option off to display 

our coordinate system grid better.  

You should now have a display similar to that shown in Figure 6.   

 
Figure 6 SAFE Main Window  

Note that the Plan View window is active. When a window is  active, the display title 

bar is highlighted. Set a window active by clicking anywhere in the window.  

Note that the Global Axes are displayed and that the Z positive is in the “up” 

direction. When SAFE refers to the direction of gravity, this is in the negative Z 

direction, or “down.”  

 

Save the Model  

Save your model often! Click the File menu > Save command. Specify the directory in which 

to save the model. For this tutorial, specify the file name as Slab.  

DisplayTitleBar 
( Active Window ) 

Units Button 

Global Axes 

  



Typically a model would be saved with the same name. However to  record work at various 

stages of development or as a backup, the File menu > Save As command can be used to 

save the file using another name.   

Step 2    Define Properties  
In this Step, material and section properties for the 

slab (area object) and beams (line objects), columns, 

and walls are defined. Note that previously defined 

materials and properties may be reviewed and 

modified using the Model Explorer window (see Figure 

7). To do this, expand any of the property items on the 

tree by clicking the + node, and then double click on 

the desired item to display the associated form.   

Figure 7 Model Explorer window  

 

Define Material Properties  

A.  Click the Define menu > Materials command to access the Materials form 

shown in Figure 8.   

 

  
                                                            Figure 8 Materials form  

B. Highlight 4000Psi in the Materials area, and click the Modify/Show Material button to display the 

Material Property Data form shown in Figure 9. That form lists the properties associated with 

4000psi concrete; this is the concrete property that will be used in our model.  



  

Figure 9 Material Property Data form 

C. Click the OK button to accept this material as defined.  

D. In the Materials area, highlight A615Gr60.  

E. Click the Modify/Show Material button to display the Material Property Data form shown in Figure 

10. This form lists the properties associated with Grade 60 reinforcing; this is the rebar property 

that will be used in our model.  

F. Click the OK button to accept this material as defined.  

G. Click the OK button on the Materials form to accept all of the defined materials.   

H. Click the File menu > Save command to save your model.  

 
                                               Figure 10 Material Property Data form  



 

 

 

 

 

WEEK 08-09 

 

BUILDING THE  PROJECT BY SAFE 

 

Define various properties of new 

model  



Define Slab and Drop Properties  

A. Click the Define menu > Slab Properties command to access the Slab Properties form shown in 

Figure 11.  

 
Figure 11 Slab Properties form 

 

B. In the Slab Property area, highlight SLAB1.  

C. Recall that for this tutorial project, the slab thickness is 10 inches. To adjust the default dimensions 

of SLAB1, click the Modify/Show Property button to access the Slab Property Data form shown 

in Figure 12.   

1. Select Slab from the Type drop-down list in the Analysis Property Data area; this ensures that 

any area object with this property assignment will be identified as a slab member.   

2. Type 10in in the Thickness edit box in the Analysis Property Data area.   

Note: Input may be done in units other than those shown on the form by explicitly stating the 

units. For example, if for this case the thickness was to be 18 inches, input could be 1.5ft, and 

the program automatically converts the number input to be consistent with the units shown 

on the form.  

3. Click the OK button to accept the changes and return to the Slab Properties form.   

 



 
Figure 12 Slab Property Data form  

D. Recall that the project has 16-inch-thick drop panels on columns. To specify a property for the drop 

panel, click the Add New Property button on the Slab Properties form and complete the following.   

1. Type DROP in the Property Name edit box on the Slab Property Data form.   

2. Select Drop from the Type drop-down list in the Analysis Property Data area.   

Note: When multiple area objects occupy the same location in plan, SAFE determines which 

property value to use in the stiffness formula based on the following hierarchy:  the Drop type 

has priority over a Slab type.  

3. Type 16 in the Thickness edit box.   

4. Click the OK button to accept the changes and return to the Slab Properties form.   

E. Click the OK button to end the slab property definitions. Click the File menu > Save command to 

save the model.   

Define Beam Properties  

A. Click the Define menu > Beam Properties command to access the Beam Properties form shown in 

Figure 13.  



 
Figure 13 Beam Properties form  

B. In the Beam Property area, highlight BEAM1.   

C. Click the Modify/Show Property button to access the Beam Property Data form shown in Figure 

14. Recall that the beams for the project are 18 inches by 24 inches.   

1. In the Analysis Property Data area, select L Beam from the Beam Shape Type drop-down list.   

In the Analysis Property Data area, type 18 into the Web Width at Top edit box, type 18 into 

the Web Width at Bottom edit box, type 24 into the Depth edit box, type 5ft into the Flange 

Width edit box, and 10 into the Slab Depth edit box.   

 

Figure 14 Beam Property Data form  

2. In the Design Property Data area, select the Flange Dimensions from Analysis Property Data 

option. This option utilizes the flange width and depth provided in the analysis property data.  

3. Click the OK button to end the beam property definition.   



D. Click the OK button to leave the Beam Properties form. Click the File menu > Save command to 

save your model.   

Define Column Properties  

A. Click the Define menu > Column Properties command to access the Column Properties form.   

B. In the Column Property area, highlight COL1.   

C. Click the Modify/Show Property button to access the Column Property Data form shown in Figure 

15. Recall that the columns for the project are 18 inches square and that the drop panels are 6 feet 

square.   

 
                                       Figure 15 Column Property Data form 

1. In the Column Section Dimensions area, select Rectangular from the Column Shape drop-down list.   

2. In the Column Section Dimensions area, type 18 into the Parallel to 2-Axis edit box and type 18 into 

the Parallel to 3-Axis edit box.   

3. Make sure that the Include Automatic Rigid Zone Area Over Column option is checked. This option 

restricts deformation of the slab at the column location, which prevents unrealistic peaks in moment 

distribution from occurring.   



In the Automatic Drop Panel Dimensions area, check the Include Automatic Drop Panel Over 

Column option. This option automatically adds a drop panel when a column with this 

property is drawn.   

4. In the Automatic Drop Panel Dimensions area, type 6ft into the Parallel to 2-Axis edit box and type 

6ft into the Parallel to 3-Axis edit box.   

5. In the Automatic Drop Panel Dimensions area, select DROP from the Slab Property drop-down list.   

6. Click the OK button to leave the Column Property Data form.   

 

D. Click the Add New Property button to access the Column Property Data form.   

1. In the General Data area, type COL-NODROP in the Property Name edit box.   

2. In the Column Section Dimensions area, select Rectangular from the Column Shape drop-down 

list.   

3. In the Column Section Dimensions area, type 18 into the Parallel to 2-Axis edit box and type 18 

into the Parallel to 3-Axis edit box.   

4. Make sure that the Include Automatic Rigid Zone Area Over Column option is checked.   

5. In the Automatic Drop Panel Dimensions area, make sure that the Include Automatic Drop 

Panel Over Column option is unchecked.   

6. Click the OK button to leave the Column Property Data form.   

E. Click the OK button to accept the Column Property definitions.   

Define Wall Properties  

A. Click the Define menu > Wall Properties command to access the Wall Properties form.   

B. In the Wall Property area, highlight Wall1.   

C. Click the Modify/Show Property button to access the Wall Property Data form shown in Figure 16. 

Recall that the walls for the project are 12 inches thick.   



 
     Figure 16 Wall Property Data form  

 

1. In the Wall Dimensions area, type 12 into the Thickness edit box.   

2. Make sure that the Include Automatic Rigid Zone Area Over Wall option is checked. This option 

restricts deformation of the slab at the wall location, which prevents unrealistic peaks in 

moment distribution from occurring.   

Click the OK button to leave the Wall Property Data form.  D.   

Click the OK button to accept the Wall Property definition.   

This completes the material and section property definition phase of the model creation. 

The slab and beam properties will be assigned in the model datum plane, while the columns 

and walls will be assigned as supports. Supports also can be assigned as point restraints, 

point springs or line springs. Support stiffnesses are calculated by SAFE based on the cross-

sectional properties, material properties, and lengths specified when the columns and walls 

are drawn.    

Step 3     Define Static Load Patterns  
 

In this Step, the dead and live static load patterns are defined. That is, we will name the 

various types of loads and specify the self-weight multipliers. The loads will be assigned to 

objects, and the values for the loads specified (uniform dead load of 30 psf and live load of 

50 psf), in Step 8.  

A. Click the Define menu > Load Patterns command to access the Load Patterns form 

shown in Figure 17.   



 
Figure 17 Load Patterns form 

B. Note that load patterns DEAD and LIVE are defined by default.    

C. Recall that the project will be analyzed for the dead load plus the self weight of the 

structure. Thus, the Self Weight Multiplier should be set equal to 1 (this will include 1.0 

times the self weight of all members) for the DEAD load. Only the DEAD load pattern 

should have a non-zero Self Weight Multiplier.  

D. Click the OK button to accept the defined static load patterns.  

E. Click the File menu > Save command. 

Step 4     Define Load Cases  
 

In this Step, the Load Cases are defined. This is where the type of analysis is specified.   

A. Click the Define menu > Load Cases command to access the Load Cases form shown in Figure 18.  

 
Figure 18 Load Cases form 

B. With the DEAD Load Case Name highlighted, click the Modify/Show Case button to display 

the Load Case Data form shown in Figure 19.  This data form changes based on the type of load 

case specified.    



1. In the Load Case Type area, select Static from the drop-down list. Modal and Hyperstatic 

also are available as load case types.   

In the Analysis Type area, select the Linear option. When working with a Static Load Case 

Type, the program offers the option to do Linear, Nonlinear (Allow Uplift), 

Nonlinear(Cracked), or Nonlinear (Long Term Cracked) analysis. For our tutorial example, 

a Static, Linear analysis will be performed for DEAD and LIVE.   

2. In the Loads Applied area, verify that the load pattern is DEAD with a scale factor of 1.   

3. Click the OK button to close the Load Case Data form.   

 
Figure 19 Load Cases Data form 

C. Review the LIVE load case, if so desired, by selecting it and using the Modify/Show Case button 

as described for the DEAD load case.  

D. Click the OK button to close the Load Cases form.  

E. Click the File menu > Save command.  
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Step 5     Draw Objects  
In this Step, slabs, columns with drops, beams, walls, and openings will be drawn.  

Draw Slabs  

Ensure that the Plan View is active (click anywhere in the display window; a window is active 

when the Display Title Bar, just below the horizontal toolbar, is highlighted). Now draw area 

objects to model the slab using the following Action Items.  

A. Click the Draw menu > Snap Options command to display the Snap Options form shown 

in Figure 20.  

 

B. In the Snap to area, make sure that the Points and Grid Intersections options are checked. 

These snap options will assist in accurately positioning objects when drawing.  

C. In the Snap Increments area, make sure that the (Imperial in Inches) Snap at length 

increments of option is checked. When drawing slab edges, beams and walls, a dimension 

line will appear. and the object will snap to the values specified in this edit box.  

D. Click the OK button to close the Snap Options form.  

E. Click the Draw menu > Draw Slabs/Areas command to access the Draw Slabs/Areas 

form shown in Figure 21. If the Draw Slabs/Areas form covers part of the model, click on 

the blue title bar, hold down the mouse button, and drag it out of the way.   

 

  
Figure 20 Snap Options form  



 
Figure 21 Draw Slabs/Areas form 

F. Make sure that the Type of Object is set to Slab. If it is not, click once in the drop-down list opposite 

the Type of Object item and  select Slab.  

G. Click in the Property drop-down list and select SLAB1. This is the slab property defined in Step 2.  

H. Click in the Edge Drawing Type drop-down list and select Straight Line. Although not used in this 

project, slab edges also may be drawn with arcs and curves.  

I. To draw the first corner of the slab, click once in the Plan View at the intersection of grid lines A 

and 7 (the cursor should display Grid Point A 7 at the correct location). Then moving clockwise 

around the grid (note how the slab edge is dimensioned as you draw), click once at these grid 

intersections in this order to draw the outline of the slab: F7, F1, D1, D3, and A3. After clicking at 

grid A3, press the Enter key on the keyboard. The shaded slab object should now appear.  

If you have made a mistake while drawing this object, click the Select menu > Select > 

Pointer/Window command to leave the Draw mode and go to the Select mode. Then click the 

Edit menu > Undo Area Add command, and repeat Items E through I.  

J. Click on the Select menu > Select > Pointer/Window command or press the Esc key on the 

keyboard to exit the Draw Slabs/Areas command.  

K. Select the slab by clicking on it anywhere. The status bar in the lower left-hand corner should show 

“1 Areas, 6 Edges selected.” If you make a mistake in selecting, press the Select menu > Clear 

Selection command and try again.  

L. Click the Edit menu > Edit Areas > Expand/Shrink Areas command to display the Expand/Shrink 

Areas form shown in Figure 22.  

M. Type 9 into the Offset Value edit box. We will use this form to expand (a positive value expands) 

the slab by 9 inches at each corner to create the perimeter overhang that is needed to 

accommodate the width of the columns (1/2 of 18 inches).  



 
                                         Figure 22 Expand/Shrink Areas form  

N. Click the OK button to finish the slab.  

O. Click the File menu > Save command to save your model.  

Draw Columns  

With the active window set as described in the preceding Draw Slabs section (i.e., Plan View window 

active and the snap to points and grid intersections enabled), use the following Action Items to draw 

columns.  

A. Click the Draw menu > Draw Columns command to access the Draw Columns form shown in Figure 

23.  

B. Click in the Property Below drop-down list and select COL1. This is the property for the 18-inch by 

18-inch column with a drop panel defined in Step 2.   

C. Click in the Property Above drop-down list and select NONE.  

There are no columns above the slab.  

 
Figure 23 Draw Columns form 

D. Click in the Height Below edit box and type 12, and click in the Height Above edit box and type 0. 

Note that the units are feet.  

E. Click in the Cardinal Point drop-down list and select 10 (Centroid).  



F. Locate the mouse cursor just above and to the left of grid intersection A6, hold down the left mouse 

button, and drag diagonally to just below and to the right of E3 and release the mouse button. 

Columns and drop panels should be placed at every grid intersec- 

tion enclosed by the window just drawn. Note how the drop panels are trimmed at the slab 

edges.  

G. Locate the mouse cursor just above and to the left of grid intersection D2, hold down the left mouse 

button, and drag diagonally to just below and to the right of E1 and then release. Again, columns 

and drop panels should be added to the grid intersections enclosed by the window.  

H. Click in the Property Below drop-down list and select COLNODROP. This is the property for the 

18-inch by 18-inch column without a drop panel for use on the perimeter.  

I. Left click once at each of the following grid locations to draw the perimeter columns: A7, B7, C7, 

D7, E7, F7, F6, F5, F4, F3, F2, and F1.  

J. Click on the Select menu > Select > Pointer/Window command or press the Esc key on the 

keyboard to exit the Draw Columns command.  

K. Locate the mouse cursor just above and to the left of grid intersection C6, hold down the left mouse 

button, and drag diagonally to just below and to the right of D5 and release the mouse button. The 

status bar in the lower left-hand corner should show “24 Points, 4 Lines, 4 Areas, 16 Edges 

selected.” If the selection is not correct, simply click the Select menu > Clear Selection command 

and try again.  

L. Click the Edit menu > Delete command or press the Delete key on the keyboard to remove the 

columns enclosed in the window. M. Click the File menu > Save command to save your model.  

N. Click the View menu > Set Default 3D View command to display the model in 3D. Note how the 

columns extend below the slab.  

O. Click the View menu > Set Plan View command to return to the Plan View before continuing the 

project.  

Draw Walls  

Similar to the preceding two sections, ensure that the Plan View is active and that the snap to points, 

grid intersections and the snap increments options are enabled. Now use the following Action Items to 

draw walls.  

A. Click the Draw menu > Draw Walls command to access the Draw Walls form shown in Figure 24.   

B. Click in the drop-down list opposite the Wall Property Below item and select WALL1. This is the 

wall property for the 12-inchthick wall defined in Step 2.  



C. Click in the Wall Property Above drop-down list and select NONE. There are no walls above the 

slab  

D. Click in the Wall Height Below edit box and type 12. Click in the Wall Height Above edit box and 

type 0.  Note that the units are feet.  

 
Figure 24 Draw Walls form  

E. Click in the drop-down list opposite the Line Drawing Type item and select Straight Line. Although 

not used in this project, walls may also be drawn with arcs and curves.  

F. Left click at grid intersection C6 to begin drawing the first wall. Draw the wall along grid line C (the 

wall is on grid line C if no angle measure is shown) past grid line 5 until the snap increments 

dimension line shows 30ft and then click again. Hit the Enter key on the keyboard to complete the 

wall. This places a wall 30 feet long along grid line C.  

If you have made a mistake while drawing this object, click the Select menu > Select > 

Pointer/Window command to leave the Draw mode and go to the Select mode. Then click the 

Edit menu > Undo Area Object Add command, and repeat Items A through F.  

 

G. Click on the Select menu > Select > Pointer/Window command or press the Esc key on the 

keyboard to exit the Draw Walls command.  

H.  Hold down the Shift key on your keyboard and right click once at the end point of the wall just 

drawn. A selection list similar to the one shown in Figure 25 appears because multiple objects exist 

at that location. In this example, two point objects and two area objects exist at the same location. 

Note that the selection list will appear only when the Shift key is used with the click.  



 
Figure 25 Selection List form 

I. Highlight the first point object and click the OK button. Because a right click action initiated the 

selection process, a Point Object Information form similar to the one shown in Figure 26, will 

display.  

 
Figure 26 Point Object Information form  

1. Click on the Geometry tab. Verify that the Point Global X and Y Coordinates are 46 and 72, 

respectively. If the coordinates are not correct, delete and re-draw the wall following the 

instructions described in Item F above.  

2. Click the OK button to leave the Point Object Information form.  

J. Click the Draw menu > Draw Walls command to access the Draw Walls form.  



K. For the next wall, located along grid line 6, left click at grid intersection C6 to begin drawing the wall 

and at intersection D6 (the snap increment dimension line should show 20ft) to designate the end 

of the wall.    

L. With the draw mode still active, draw the last wall along grid line D past grid line 5 until the snap 

increments dimension line shows 30 and then click again. 

M. Hit the Enter key on the keyboard to complete the wall. This wall should be parallel to the first wall 

drawn.  

N. Click on the Select menu > Select > Pointer/Window command or press the Esc key on the 

keyboard to exit the Draw Walls command. Your model should look similar to Figure 27.  

 
Figure 27 The model after drawing columns and walls 

Draw Beams  

Similar to the previous sections, ensure that the Plan View is active and the snap to points and grid 

intersections features are enabled. Draw the beams as follows.   

A. Click the Draw menu > Draw Beams/Lines command to access the Draw Beams/Lines form 

shown in Figure 28.   

 
Figure 28 Draw Beams/Lines form 

 



B. Click in the drop-down list opposite the Property item and select BEAM1. Recall that BEAM1 is the 

18-inch by 24-inch beam defined in Step 2.  

C. Click in the Line Drawing Type drop-down list and select Straight Line.  

D. Left click once at the grid intersection A7. Click again at grid intersections F7, followed by F1. 

Although only one beam per side was drawn, the program will automatically mesh this single object 

internally into multiple beam elements to provide the correct connectivity to the supporting 

columns and slab elements.  

E. Click on the Select menu > Select > Pointer/Window command or press the Esc key on the 

keyboard to exit the Draw Beams command.  

F. Click the File menu > Save command to save your model.  

Draw Openings (Area Objects)  

Similar to the previous sections, ensure that the Plan View is active and the snap to points and grid 

intersections features are enabled. Draw an area object to model the opening as follows:   

A. Click the Draw menu > Draw Rectangular Slabs/Areas command to display the Draw 

Rectangular Slabs/Areas form shown in Figure 29.  

B. Click once in the drop-down list opposite the Type of Object item and select Opening.  

 
Figure 29 Draw Rectangular Slabs/Areas form  

C. Left click at the intersection of grid lines C and 6, and while holding the left mouse button 

down, move diagonally down to the wall end point located along grid line D between 

grids 4 and 5 and release the button. An area object with different shading should appear, 

indicating that an opening for the stairs has been drawn. An opening takes priority over 

an object with assigned slab properties when the program determines the stiffness 

formulation.  

D. Click on the Select menu > Select > Pointer/Window command or press the Esc key on 

the keyboard to exit the Draw Rectangular Slabs/Areas command.  

E. Click the File menu > Save command to save your model.  



Step 6     Add Design Strips  
In this step, design strips will be added to the model. Design strips determine how reinforcing 

will be calculated and positioned in the slab. Forces are integrated across the design strips 

and used to calculate the required reinforcing for the selected design code. Typically design 

strips are positioned in two principal directions:  Layer A and Layer B.  

Similar to the previous sections, ensure that the Plan View is active and the snap to points and 

grid intersections features are enabled. Add design strips to the model as follows:  

A. Click the Edit menu > Add/Edit Design Strips > Add Design Strips command to display the 

Add Design Strips form shown in Figure 30.  

B. In the Options area, select the Add Design Strips Along Cartesian Grid Lines option. Make sure 

that the Include Middle Strip option is checked  

C. In the Parameters area, click in the Grid Direction drop-down list and select X.  

 
Figure 30 Add Design Strips form 

D. Select A from the Strip Layer drop-down list.  

E. Select the Auto option. The added design strips will automatically adjust their width to align with 

adjacent strips.  

F. Click the OK button to leave the Add Design Strips form. Design strips in the X-axis direction should 

now appear as solid lines.  



G. Left click on the design strips that lie below grid line 3 to select them; the status bar in 

the lower left-hand corner should show “4 Design Strips selected.” If the selection 

H. is not correct, simply click the Select menu > Clear Selection command and try again.  

I. Left click on the slab (anywhere except at a column, drop panel, beam or design strip location) to 

select it; the status bar in the lower left-hand corner should now show “1 Areas, 6 Edges, 4 Design 

Strips selected.”  

J. Left click at the left ends of the 4 selected design strips; the status bar in the lower left-hand corner 

should now show “4 Points, 1 Areas, 6 Edges, 4 Design Strips selected.”  

K. Click the Edit menu > Align Points/Lines/Edges command to display the Align Points/Lines/Edges 

form shown in Figure 31. K. Select the Trim Line/Edge/Tendon/Strip Objects option.  

 
Figure 31 Align Points/Lines/Edges form 

L. Click the OK button to leave the Align Points/Lines/Edges form. The design strips below grid line 

3 should now be trimmed to the edge of the slab.  

M. Left click on the design strip that lies on grid line 5 to select it; the status bar in the lower left-

hand corner should show “1 Design Strips selected.”  

N. Press the Delete key on the keyboard to remove the selected design strip from the model.  

O. Click the Draw menu > Draw Design Strips command to display the Draw Design Strips form 

shown in Figure 32.  

 
Figure 32 Draw Design Strips form 

P. Select A from the Strip Layer drop-down list.  



Q. Select Column Strip from the Strip Design Type drop-down list.  

R. Type 4.5 into the Start Width Left edit box.  

S. Type 6 into the Start Width Right edit box.  

T. Type 4.5 into the End Width Left edit box and type 6 into the End Width Right edit box.  

U. Left click at grid intersection A5 and at C5, and then click the right mouse button to stop 

drawing.  

V. Left click at grid intersection D5 and at F5.  

W. Press the Esc key on the keyboard to leave the Draw command.  

X. Click the Edit menu > Add/Edit Design Strips > Add Design Strips command to display the 

Add Design Strips form. Y. Select Y from the Grid Direction drop-down list.  

Z. Click in the Strip Layer edit box and select B from the drop-down list.  

AA. Click the OK button to leave the Add Design Strips form. Design strips in the Y-axis direction should now appear 

as solid lines.  

BB. Left click on the design strips that lie to the left of grid line D to select them; the status bar in the lower left-hand 

corner should show “6 Design Strips selected.”  

CC. Left click on the slab (anywhere except at a column, drop panel, beam or design strip location) to select it; the 

status bar in the lower left-hand corner should now show “1 Areas, 6 Edges, 6 Design Strips selected.”  

DD. Left click at the bottom ends of the selected design strips; the status bar in the lower left-hand corner should 

now show “6 Points, 1 Areas, 6 Edges, 6 Design Strips selected.”  

EE. Click the Edit menu > Align Points/Lines/Edges command to display the Align Points/Lines/Edges form.  

FF. Select the Trim Line/Edge/Tendon/Strip Objects option.  

GG. Click the OK button to leave the Align Points/Lines/Edges form. The Y direction design strips to the left of grid 

line D should now be trimmed to the edge of the slab.  The trimming of the design strips was done for display 

purposes only; the program will automatically ignore the portion of a design strip that extends beyond a slab 

edge.  

HH. Click the File menu > Save command to save your model.  



Step 7     Set Display Options  
In this Step, the set display options will be used to alter the objects displayed.  

A. Click the View menu > Set Display Options command. When the Set Display Options form 

displays, uncheck the Design Strip Layer A and Design Strip Layer B check boxes in the Items 

Present in View area, as shown in Figure 33. This action will turn off the display of the design 

strips.  

 

B. Click the OK button to accept the changes, and the model now appears as shown in Figure 34.   

 
Figure 34 Model after all objects have been drawn 

 

 

  
Figure 33 Set Display Options form  



 

 

WEEK 12-13 

 

BUILDING THE  PROJECT BY SAFE 

 

Assign Loads, Analysis 



Step 8     Assign Loads  
In this Step, the dead and live loads will be assigned to the slab. Ensure that the Plan View is 

still active, and that the program is in the select mode (Draw menu > Select > 

Pointer/Window command).  

A. Select the slab by clicking on it anywhere that is not a beam, wall, column, drop panel or opening. The 

status bar in the lower lefthand corner should show “1 Areas, 6 Edges selected.” If you make a mistake 

in selecting, click the Select menu > Clear Selection command, and try again.   

B. Click the Assign menu > Load Data > Surface Loads command to access the Surface Loads form 

shown in Figure 35.  

C. If it is not selected already, select DEAD from the Load Pattern Name drop-down list.  

D. Select Gravity from the Direction drop-down list in the Load Direction area.  

 
Figure 35 Surface Loads form  

E. In the Uniform Loads area, type 30 in the Uniform Load edit box.  

Note: Additional load patterns may be defined by clicking on the “…” button next to the load 

pattern name. A “…” button returns you to the form used to define the item in the adjacent 

drop-down list or edit box, which in this case is the Load Patterns form.   

F. Click the OK button to accept the dead load assignment. SAFE will display the loads on the model. Use 

the Assign menu > Clear Display of Assigns command to remove the assignments from the display, 

if desired.   

G. Click anywhere on the main slab to reselect the slab, or click the Select menu > Get Previous Selection 

command to select the slab.  

H. Click the Assign menu > Load Data > Surface Loads command to again access the Surface Loads 

form.  



I. Select LIVE from the Load Pattern Name drop-down list.  

J. Type 50 in the Uniform Load edit box in the Uniform Loads area.  

K. Click the OK button to accept the live load assignment. Again, use the Assign menu > Clear Display 

of Assigns command to remove the assignments from the display.  

L. To review the assignments to the slab, right click on the slab anywhere that is not a beam, wall, column, 

drop-panel or opening to access the Slab-Type Area Object Information form shown in Figure 36.   

M. Select the Loads tab and note that the DEAD Load Pattern has a Load Value of 30lb/ft2, and that the 

LIVE Load Pattern has a Load Value of 50lb/ft2.   

N. Click the OK button to close the Slab-Type Area Object Information form.   

O. Click the File menu > Save command to save your model.  

 
Figure 36 Slab-Type Area Object Information form  

Step 9     Run the Analysis and Design  
In this Step, the analysis and design will be run.  

A. Click the Run menu > Run Analysis & Design command to start the analysis. The 

program will create the analysis model from your object-based SAFE model and will 

display information in the status bar in the lower left-hand corner as the analysis and 

design proceeds. Additional information about the run may be accessed at a later time 



using the File menu > Show Input/Output Text Files command and selecting the 

filename with a .LOG extension.   

When the analysis and design are finished, the program automatically displays a 

deformed shape view of the model, and the model is locked. The model is locked when 

the Options menu > Lock/Unlock Model icon  appears depressed. Locking the 

model prevents any changes to the model that would invalidate the analysis results.  

10    Graphically Review the Analysis Results  
In this Step, the analysis will be reviewed using graphical displays of the results.  

A. Click the View menu > Set Default 3D View command to display the deformed shape for the DEAD 

load case in 3D.  

B. Click the Start Animation button in the lower right-hand corner of the display to animate the 

deformed shape. Speed of the animation may be adjusted by using the slider control adjacent to 

the button. Click the Stop Animation button to end the animation.     

C. Click the Display menu > Show Deformed Shape command to access the Deformed Shape form 

shown in Figure 37.  

 
Figure 37 Deformed Shape form  

D. In the Load Case/Load Combination area, select the Load Case option.  

E. Select LIVE from the Load Case drop-down list.  



F. Select the Automatic option in the Scaling area.  

G. Check the Draw Contours checkbox in the Contour Range area.  

H. Click the OK button to generate a 3-D deformed shape with contours for the LIVE load case.  

I. Click the Display menu > Show Slab Forces/Stresses command to bring up the Slab 

Forces/Stresses form shown in Figure 38.  

 
Figure 38 Slab Forces/Stresses form  

J. Select LIVE from the Load Case drop-down list.  

K. Select the Resultant Forces option in the Component Type area.  

L. Select the M22 option in the Component area.  

M. Select the Display Contours on Deformed Shape option in the Display Options area.  

N. Click the OK button to generate the moment diagram shown in Figure 39.   



 
Figure 39 M22 Moment Diagram  

Note that as you move the cursor over the moment diagram, the values are displayed at 

the cursor and in the lower left-hand corner of the window.  

O. Click the Display menu > Show Undeformed Shape command to clear the display of the moment 

diagram.  

P. Click the View menu > Set Plan View command to return to the Plan View.  
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Step 11    Design Display  
In this Step, design results for the slab and beams will be displayed. Note that the design was 

run along with the analysis in Step 9. Design results are for the ACI 318-08 code, which was 

selected in Step 1. Design preferences may be reviewed or changed by going to the Design 

menu >  Step 11    Design Display 

Design Preferences command (some design preferences are also set on the section property data 

forms); be sure to re-run the analysis and design (Step 9) if changes to the preferences are made.   

A. Click the Display menu > Show Slab Design command to access the Slab Design form shown in 

Figure 40.  

 
Figure 40 Slab Design form  

B. In the Choose Display Type area, select Strip Based from the Design Basis drop-down list and 

Enveloping Flexural Reinforcement from the Display Type drop-down list.  

C. In the Choose Strip Direction area, check the Layer A checkbox and uncheck the Layer B checkbox. 

This will display the design results in the Layer A (X) direction only.  

D. In the Rebar Location Shown area, check the Show Top Rebar checkbox and uncheck the Show 

Bottom Rebar checkbox.  

E. In the Reinforcing Display Type area, select the Show Total Rebar Area for Strip option.  

F. Click the OK button to leave the Slab Design form and display the slab design results. The top 

flexural reinforcing required in the Layer A direction is displayed for both column and middle strips.   



Positioning the cursor at any location on a Layer A design strip causes the required top and 

bottom reinforcing values to be displayed at the cursor and in the lower left corner of the 

window.   

G. To view the required reinforcing in the other direction, click the Display menu > Show Slab Design 

command to display the Slab Design form.  

H. In the Choose Display Type area, select Finite Element Based from the Design Basis drop-down list. 

This option displays the required reinforcing calculated on an element-by-element basis as intensity 

contours - integration across the defined design strips is not performed.  

I. In the Reinforcing Direction and Location area, select the Direction 2 – Bottom Rebar option. 

Direction 2 refers to the object local axis 2 direction.  

J. In the Show Rebar Above Specified Value area, select the None option.  

K. Click the OK button to leave the Slab Design form and display the slab design results for the local 

axis 2 direction. The view will be updated to that shown in Figure 41. Again, positioning the cursor 

anywhere on the slab will result in the display of the reinforcing values at the cursor and in the 

lower left-hand corner of the SAFE window.  

 
Figure 41 Direction 2 reinforcing  

L. To view the required reinforcing in the beams, click the Display menu > Show Beam Design 

command. The Beam Design form shown in Figure 42 displays.   

M. In the Choose Display Type area, select Longitudinal Rebar from the Display Type drop-down list 

and Flexure from the Rebar Type drop-down list.  

N. Review the other selected options and then click the OK button to close the Beam Design form.  



The view will be updated to show the flexural reinforcing required in the beams along the two 

perimeter sides. Positioning the cursor on the beams will result in the display of the reinforcing 

values in the lower left-hand corner and at the cursor.  

 

 
Figure 42 Beam Design form  

O. Right click on a beam to display the Design Details form shown in Figure 43.   

 
Figure 43 Design Details form  

Scroll through the form to see all of the design information associated with the selected 

beam. Click the X button in the top-right corner of the form to close the form.  



Step 12   Run Detailing   
In this Step, detailing will be run and displayed. Detailing may be run only after analysis and 

design are complete.  

A. Click the Detailing menu > Detailing Preferences command to display the Detailing 

Preferences form shown in Figure 44. Use this form to set the regional standards, to 

control how dimensioning is displayed, to manage reinforcing bar notation, and to select 

the units for material quantity takeoffs.  

  
Figure 44 Detailing Preferences form  

B. Review the settings on this form (we will accept the default selections), and then click the 

OK button to close the form.  

C. Click the Detailing menu > Slab/Mat Reinforcing Preferences to display the Slab/Mat 

Detailing Preferences form shown in Figure 45.   



 
Figure 45 Slab/Mat Detailing Preferences form 

D. Click the General and Display tab. On this tab review or alter the rebar curtailment, detailing 

and callout options, as well as set how sections should be cut. We will accept the default 

settings.  

E. Click the Rebar Selection tab and review or change the rebar selection rules, preferred sizes, 

minimums and reinforcing around openings. We will accept the default settings.  

F. Click the OK button to accept the selections and close the form.  

G. Click the Detailing menu > Drawing Sheet Setup command to display the Drawing Sheet Setup 

form. The sheet size, scales, title block and text sizes can be reviewed and changed using this 

form.  

We will accept the default settings.  

H. Click the OK button to close the form.  

I. Review the line thicknesses and styles by clicking the Detailing menu > Drawing Format 

Properties command.  

J. Click the OK button to accept the selections and close the form.  

K. Now that the detailing preferences and drawing setup options have been reviewed, click the 

Run menu > Run Detailing command to generate the detailing drawings. A framing plan is 

displayed when detailing is complete.  

L. Click the Detailing menu > Show Detailing command to access the Display Detailing Item form 

shown in Figure 46.  



 
Figure 46 Display Detailing Item form 

 

M. Select the Drawing option. 

N. Select Slab Rebar Plan – Bottom Bars from the Drawing dropdown list.  

O. Click the OK button to leave the Display Detailing Item form and display the selected 

drawing shown in Figure 47.  

P. Clicking on the Detailing tab in the Model Explorer and expanding the Views and Drawing 

Sheets trees also provides access to detailing drawings and component views.  

Q. Click the Display menu > Show Undeformed Shape command to return to the model.  



 
Figure 47 Slab Rebar Plan  

Step 13   Create Report   
In this Step, a report describing model input and output results will be created.   

A. Click the File menu > Report Setup command to display the Report Setup Data form.  

B. In the Report Output Type area, be sure that the RTF File option is selected.  

C. In the Report Items area, uncheck the Include Hyperlinked Contents checkbox.  

D. Click the OK button to leave the Report Setup Data form.  

E. Click the File menu > Create Report command to display the Microsoft Word Rich Text File Report 

form.  

F. Type Slab in the File name edit box and click the Save button. A report, with a cover similar to that 

shown in Figure 48 should be displayed in your word processor, and will be saved to your hard disk.  



 
Figure 48 Cover Page for Report  

G. Scroll through the report to find tables that list geometry and properties, analysis results and design 

information, such as that shown if Figure 49.  

H. Close your word processor and return to the SAFE program.  

I. Click the File menu > Save command to save your model one last time.  



 
Figure 49 Typical Report information 

Congratulations! You’ve successfully created, analyzed, designed, detailed, and reviewed a SAFE 

reinforced concrete model.  
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